On Tue, May 30, 2017 at 11:58 AM, Bartosz Golaszewski <brgl@xxxxxxxx> wrote: > We currently shift bits here and there without actually explaining > what we're doing. Add some helper variables with names indicating > their purpose to improve the code readability. > + /* Each chip is described by two values. */ > + num_chips = gpio_mockup_params_nr / 2; > + > + chips = devm_kzalloc(dev, sizeof(*chips) * num_chips, GFP_KERNEL); It's effectively devm_kcalloc() or devm_kmalloc_array() depending on the requirement of zeroing a memory chunks. -- With Best Regards, Andy Shevchenko -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html