On Thu, Apr 27, 2017 at 10:19 AM, Jacopo Mondi <jacopo+renesas@xxxxxxxxxx> wrote: > Add PIN_CONF_UNPACK_PARAM and PIN_CONF_UNPACK_ARGS macros useful to > unpack generic properties and their arguments > > Signed-off-by: Jacopo Mondi <jacopo+renesas@xxxxxxxxxx> (...) /* * Helpful configuration macro to be used in tables etc. Then this should say "macros" rather than "macro". > -#define PIN_CONF_PACKED(p, a) ((a << 8) | ((unsigned long) p & 0xffUL)) > +#define PIN_CONF_PACKED(p, a) (((a) << 8) | ((unsigned long) (p) & 0xffUL)) Also adding some extra parantheses I see. > +#define PIN_CONF_UNPACK_PARAM(c) ((c) & 0xffUL) > +#define PIN_CONF_UNPACK_ARGS(c) ((c) >> 8) But why. I have these two static inlines just below your new macros: static inline enum pin_config_param pinconf_to_config_param(unsigned long config) { return (enum pin_config_param) (config & 0xffUL); } static inline u32 pinconf_to_config_argument(unsigned long config) { return (u32) ((config >> 8) & 0xffffffUL); } Why can't you use this in your code instead of macros? We generally prefer static inlines over macros because they are easier to read. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html