Hi Arnd, On Tue, May 3, 2016 at 8:56 PM, Arnd Bergmann <arnd@xxxxxxxx> wrote: > A conflict of two patches caused a build error when a function got renamed > but a new user appeared in the other patch: > > drivers/pinctrl/bcm/pinctrl-ns2-mux.c:540:17: error: 'pinctrl_utils_dt_free_map' undeclared here (not in a function) > .dt_free_map = pinctrl_utils_dt_free_map, > ^~~~~~~~~~~~~~~~~~~~~~~~~ > > This renames the new user of pinctrl_utils_dt_free_map accordingly. > > Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx> > Fixes: d32f7fd3bbc3 ("pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map") > Fixes: b5aa1006e4a9 ("pinctrl: ns2: add pinmux driver support for Broadcom NS2 SoC") > --- > drivers/pinctrl/bcm/pinctrl-ns2-mux.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/pinctrl/bcm/pinctrl-ns2-mux.c b/drivers/pinctrl/bcm/pinctrl-ns2-mux.c > index 1fd57db52d7b..3fefd14acc3e 100644 > --- a/drivers/pinctrl/bcm/pinctrl-ns2-mux.c > +++ b/drivers/pinctrl/bcm/pinctrl-ns2-mux.c > @@ -537,7 +537,7 @@ static struct pinctrl_ops ns2_pinctrl_ops = { > .get_group_pins = ns2_get_group_pins, > .pin_dbg_show = ns2_pin_dbg_show, > .dt_node_to_map = pinconf_generic_dt_node_to_map_pin, > - .dt_free_map = pinctrl_utils_dt_free_map, > + .dt_free_map = pinctrl_utils_free_map, > }; > > static int ns2_get_functions_count(struct pinctrl_dev *pctrl_dev) > -- > 2.7.0 > Looks good to me. Thanks Dhananjay -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html