Re: [RFT][PATCH v2 3/3] gpio: mpc8xxx: Slightly update the code for better readability

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2/22/2016 3:25 PM, Axel Lin wrote:
> Setting gc->direction_output to gc->direction_output looks strange.
> I think this change makes the intention more clear.
>
> Signed-off-by: Axel Lin <axel.lin@xxxxxxxxxx>
> ---
>  drivers/gpio/gpio-mpc8xxx.c | 7 +++++--
>  1 file changed, 5 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpio/gpio-mpc8xxx.c b/drivers/gpio/gpio-mpc8xxx.c
> index bc042ad6..425501c 100644
> --- a/drivers/gpio/gpio-mpc8xxx.c
> +++ b/drivers/gpio/gpio-mpc8xxx.c
> @@ -339,8 +339,11 @@ static int mpc8xxx_probe(struct platform_device *pdev)
>  	 */
>  	mpc8xxx_irq_chip.irq_set_type = devtype->irq_set_type;
>  
> -	gc->direction_output = devtype->gpio_dir_out ?: gc->direction_output;
> -	gc->get = devtype->gpio_get ?: gc->get;
> +	if (devtype->gpio_dir_out)
> +		gc->direction_output = devtype->gpio_dir_out;
> +	if (devtype->gpio_get)
> +		gc->get = devtype->gpio_get;
> +
>  	gc->to_irq = mpc8xxx_gpio_to_irq;
>  
>  	ret = gpiochip_add_data(gc, mpc8xxx_gc);
Ok, maybe it's more clear.

Liu Gang
--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux SPI]     [Linux Kernel]     [Linux ARM (vger)]     [Linux ARM MSM]     [Linux Omap]     [Linux Arm]     [Linux Tegra]     [Fedora ARM]     [Linux for Samsung SOC]     [eCos]     [Linux Fastboot]     [Gcc Help]     [Git]     [DCCP]     [IETF Announce]     [Security]     [Linux MIPS]     [Yosemite Campsites]

  Powered by Linux