On Fri, Mar 21, 2025 at 3:37 AM Koichiro Den <koichiro.den@xxxxxxxxxxxxx> wrote: > > On Thu, Mar 20, 2025 at 04:51:04PM GMT, Bartosz Golaszewski wrote: > > On Sat, Mar 15, 2025 at 5:41 PM Koichiro Den <koichiro.den@xxxxxxxxxxxxx> wrote: > > > > > > Prepare for the upcoming configfs interface. These functions will be > > > used by both the existing sysfs interface and the new configfs > > > interface, reducing code duplication. > > > > > > No functional change. > > > > > > Signed-off-by: Koichiro Den <koichiro.den@xxxxxxxxxxxxx> > > > --- > > > > > > +static int aggr_alloc(struct gpio_aggregator **aggr, size_t arg_size) > > > +{ > > > + struct gpio_aggregator *new __free(kfree) = NULL; > > > + int ret; > > > + > > > + new = kzalloc(sizeof(*new) + arg_size, GFP_KERNEL); > > > > Please prefer declaring the auto variable and initializing it at the > > same time. Should be: > > > > struct gpio_aggregator *new __free(kfree) = kzalloc(...); > > Thanks for the review. Should I send v7 for this change? > You should send one anyway once v6.15-rc1 is tagged. Bartosz