Hi Prabhakar, Thanks for your patch! On Tue, Jun 18, 2024 at 7:48 PM Prabhakar <prabhakar.csengg@xxxxxxxxx> wrote: > From: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx> > > The `PIN_CFG_VARIABLE` macro did not indicate the capabilities of a pin > but served as a flag indicating that the pins of a port have different > capabilities. > > To better reflect its purpose, move the `PIN_CFG_VARIABLE` macro beside > `RZG2L_SINGLE_PIN` and rename it to `RZG2L_CFG_VARIABLE`. Additionally, Do you mind me renaming it to RZG2L_VARIABLE_CFG while applying? > introduce new macros for packing variable port configurations: > > - `RZG2L_GPIO_PORT_PACK_VARIABLE(n, a)`: Combines `RZG2L_CFG_VARIABLE` > with `RZG2L_GPIO_PORT_PACK` to handle variable pin configurations > for a packed port. > - `RZG2L_GPIO_PORT_SPARSE_PACK_VARIABLE(m, a)`: Combines > `RZG2L_CFG_VARIABLE` with `RZG2L_GPIO_PORT_SPARSE_PACK` to handle > variable pin configurations for a sparse port. > > Due to the above change the configuration macros have been reorganized > as follows: > - Shift the bit positions of `PIN_CFG_NOGPIO_INT`, `PIN_CFG_NOD`, > `PIN_CFG_SMT`, `PIN_CFG_ELC`, and `PIN_CFG_IOLH_RZV2H` down by one > to accommodate the removal of `PIN_CFG_VARIABLE`. > > Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx> Reviewed-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx> i.e. will queue in renesas-pinctrl for v6.11. Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds