On Friday 05 September 2014 12:02:01 Shevchenko, Andriy wrote: > > irq = irq_of_parse_and_map(node, 0); > > If (!irq) { > > pp->irq = -1; > > return; > > } else { > > pp->irq = irq; > > } > > Then the code looks strange. > > > > How do you think? > > If I understood correctly you messed up with hwirq vs. virq. > Otherwise you have mention that you are using virq everywhere (I guess > you may rename the field in the structure), but in this case the field > in the platform_data looks a bit strange. The field in platform_data should be the mapped virtual irq number, it makes no sense to use the hwirq unless you also add a pointer to the domain in which that hwirq exists. Also the output of irq_of_parse_and_map() is a mapped irq, as the name suggests. Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html