> +static int dm_blk_reserve_space(struct block_device *bdev, sector_t nr_sects) > +{ > + > +static int dm_blk_get_reserved_space(struct block_device *bdev, > + sector_t *nr_sects) > +{ These two functions are almost identical, what about refactoring it to a single function like dm_blk_reserved_space(), and maybe adding a flags argument, for choosing between set/get reserved space? Or maybe just add the common parts of these two functions inside a helper function or a macro?! -- Carlos -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html