On Wed, Nov 4, 2015 at 3:33 AM, Andreas Dilger <adilger@xxxxxxxxx> wrote: > On Nov 3, 2015, at 8:16 AM, Andreas Gruenbacher <agruenba@xxxxxxxxxx> wrote: >> @@ -3667,7 +3674,7 @@ EXPORT_SYMBOL(dentry_unhash); >> >> int vfs_rmdir(struct inode *dir, struct dentry *dentry) >> { >> - int error = may_delete(dir, dentry, 1); >> + int error = may_delete(dir, dentry, true, false); > > This is a prime example why passing "true" and "false" as function arguments > is not very useful, and especially prone to bugs when there are two of them. > > That said, this is code originally from Al, so he may have a different > opinion. Have you checked how vfs_rename uses the is_dir and new_is_dir variables? Using file modes there probably won't help readability. An enum maybe? Thanks, Andreas -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html