Re: [PATCH] coredump: Replace opencoded set_mask_bits()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Aug 07, 2015 at 08:14:03PM +0530, Vineet Gupta wrote:

> See, I have such a cmpxchg loop in ARC code - originally from Peter :-)
> arch/arc/kernel/smp.c. @ipi_data_ptr is NOT atomic_t
> 
> 	do {
> 		new = old = ACCESS_ONCE(*ipi_data_ptr);
> 		new |= 1U << msg;
> 	} while (cmpxchg(ipi_data_ptr, old, new) != old);
> 

Well, you'll have atomic_or() real soon now.
--
To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux Ext4 Filesystem]     [Union Filesystem]     [Filesystem Testing]     [Ceph Users]     [Ecryptfs]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [Samba]     [Device Mapper]     [CEPH Development]
  Powered by Linux