Hi Jan, Thanks for your review and sorry for delay, I was on vacation. On 07/28, Jan Kara wrote: > > On Wed 22-07-15 23:15:41, Oleg Nesterov wrote: > > > > Perhaps we should also cleanup the usage of ->frozen. It would be > > better to set/clear (say) SB_FREEZE_WRITE with the corresponding > > write-lock held. Currently freeze_super() has to set SB_FREEZE_WRITE > > before sb_wait_write(SB_FREEZE_WRITE) to avoid the race with itself, > > we can add another state. The "From now on, no new normal writers > > can start" removed by this patch was not really correct. > > The patch looks good, just one question: Why wasn't the above comment > really correct? It is not that I think it was wrong, just not 100% accurate even before this change. "w_writers.frozen = SB_FREEZE_WRITE" itself can't guarantee that "no new normal writers can start". We do not know when other CPU's will see the result of this STORE. > Do you mean it wouldn't be correct after your changes? I > agree with that. Yes, yes, this was the actual reason to remove this comment. Sorry for confusion. > Also when you'd like to "cleanup the usage of ->frozen", you have to be > careful no only about races with freeze_super() itself but also about races > with remount (that's one of the reasons why we use s_umount for protecting > modifications of ->frozen). So I'm not sure how much we can actually > improve on code readability... Yes, me too. Probably I should simply remove this (confusing) part of the changelog. > Anyway, you can add: > > Reviewed-by: Jan Kara <jack@xxxxxxxx> Thanks! OK. Now I'll try to actually test this all. Hopefully this week. Oleg. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html