Next pile: debugfs patches, mostly to make it possible for something like tracefs to be transparently automounted on given directory in debugfs. New primitive in there is debugfs_create_automount(name, parent, func, arg), which creates a directory and makes its ->d_automount() return func(arg). Another missing primitive was debugfs_create_file_size() - open-coded in quite a few places. Dave's patch adds it and converts the open-code instances to calling it. BTW, this branch differs from what had been merged into #for-next in one respect - I'd added my s-o-b to the last commit. Otherwise they are identical (i.e. the same parent and tree SHA1 in there); hopefully, merging that one in mainline won't confuse git into conflicts for linux-next... Please, pull from git://git.kernel.org/pub/scm/linux/kernel/git/viro/vfs.git debugfs_automount Shortlog: Al Viro (11): debugfs_{mkdir,create,link}(): get rid of redundant argument debugfs: split the beginning and the end of __create_file() off debugfs: kill __create_file() fold debugfs_link() into caller debugfs_mknod(): get rid useless arguments fold debugfs_mkdir() into caller fold debugfs_create() into caller fold debugfs_mknod() into callers debugfs: take mode-dependent parts of debugfs_get_inode() into callers debugfs: split end_creating() into success and failure cases new primitive: debugfs_create_automount() David Howells (1): debugfs: Provide a file creation function that also takes an initial size Diffstat: drivers/infiniband/hw/cxgb4/device.c | 35 +-- drivers/net/ethernet/chelsio/cxgb4/cxgb4_debugfs.c | 9 +- drivers/scsi/csiostor/csio_init.c | 9 +- drivers/usb/gadget/udc/atmel_usba_udc.c | 15 +- fs/debugfs/inode.c | 291 ++++++++++++--------- include/linux/debugfs.h | 18 ++ 6 files changed, 212 insertions(+), 165 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html