NeilBrown <neilb@xxxxxxx> wrote: > The current "wait_on_bit" interface requires an 'action' function > to be provided which does the actual waiting. > There are over 20 such functions, many of them identical. > Most cases can be satisfied by one of just two functions, one > which uses io_schedule() and one which just uses schedule(). > > So: > Rename wait_on_bit and wait_on_bit_lock to > wait_on_bit_action and wait_on_bit_lock_action > to make it explicit that they need an action function. > > Introduce new wait_on_bit{,_lock} and wait_on_bit{,_lock}_io > which are *not* given an action function but implicitly use > a standard one. > The decision to error-out if a signal is pending is now made > based on the 'mode' argument rather than being encoded in the action > function. Yay! About time! This is something I've wanted to do for ages, but never quite got around to. Acked-by: David Howells <dhowells@xxxxxxxxxx> -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html