Hi, On Tue, 2014-03-04 at 11:00 +0100, Karel Zak wrote: > Move the magic number to proper place. > I'm not convinced that it makes sense to move this to a shared header, outside of gfs2_ondisk.h unless it is needed by some other subsystem or component. That doesn't appear to be the case here, Steve. > CC: Steven Whitehouse <swhiteho@xxxxxxxxxx> > Signed-off-by: Karel Zak <kzak@xxxxxxxxxx> > --- > include/uapi/linux/gfs2_ondisk.h | 2 +- > include/uapi/linux/magic.h | 1 + > 2 files changed, 2 insertions(+), 1 deletion(-) > > diff --git a/include/uapi/linux/gfs2_ondisk.h b/include/uapi/linux/gfs2_ondisk.h > index 0f24c07..06a05d9 100644 > --- a/include/uapi/linux/gfs2_ondisk.h > +++ b/include/uapi/linux/gfs2_ondisk.h > @@ -11,8 +11,8 @@ > #define __GFS2_ONDISK_DOT_H__ > > #include <linux/types.h> > +#include <linux/magic.h> > > -#define GFS2_MAGIC 0x01161970 > #define GFS2_BASIC_BLOCK 512 > #define GFS2_BASIC_BLOCK_SHIFT 9 > > diff --git a/include/uapi/linux/magic.h b/include/uapi/linux/magic.h > index f8ccce1..14f2a96 100644 > --- a/include/uapi/linux/magic.h > +++ b/include/uapi/linux/magic.h > @@ -14,6 +14,7 @@ > #define CRAMFS_MAGIC 0x28cd3d45 /* some random number */ > #define CRAMFS_MAGIC_WEND 0x453dcd28 /* magic number with the wrong endianess */ > #define DEBUGFS_MAGIC 0x64626720 > +#define GFS2_MAGIC 0x01161970 > #define MQUEUE_MAGIC 0x19800202 > #define SECURITYFS_MAGIC 0x73636673 > #define SELINUX_MAGIC 0xf97cff8c -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html