On Tue, 2014-03-04 at 11:00 +0100, Karel Zak wrote: > Move the magic number to proper place. > > Signed-off-by: Karel Zak <kzak@xxxxxxxxxx> > --- > fs/hfsplus/hfsplus_raw.h | 2 +- > include/uapi/linux/magic.h | 1 + > 2 files changed, 2 insertions(+), 1 deletion(-) > > diff --git a/fs/hfsplus/hfsplus_raw.h b/fs/hfsplus/hfsplus_raw.h > index 8ffb3a8..73b2701 100644 > --- a/fs/hfsplus/hfsplus_raw.h > +++ b/fs/hfsplus/hfsplus_raw.h > @@ -14,6 +14,7 @@ > #define _LINUX_HFSPLUS_RAW_H > > #include <linux/types.h> > +#include <linux/magic.h> > > /* Some constants */ > #define HFSPLUS_SECTOR_SIZE 512 > @@ -21,7 +22,6 @@ > #define HFSPLUS_VOLHEAD_SECTOR 2 > #define HFSPLUS_VOLHEAD_SIG 0x482b > #define HFSPLUS_VOLHEAD_SIGX 0x4858 > -#define HFSPLUS_SUPER_MAGIC 0x482b Frankly speaking, HFSPLUS_VOLHEAD_SIGX is also magic number. The HFSPLUS_SUPER_MAGIC ('H+') is magic for HFS+ volumes. And HFSPLUS_VOLHEAD_SIGX ('HX') is magic for HFSX volumes. But, moreover, as I can see HFSPLUS_VOLHEAD_SIG is synonym for HFSPLUS_SUPER_MAGIC. And it is used more frequently in HFS+ driver code. So, maybe, it makes sense to clean up duplication in declarations. Thanks, Vyacheslav Dubeyko. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html