[PATCH 19/22] romfs: move ROMFS_MAGIC to <linux/magic.h>

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Move the magic number to proper place.

Signed-off-by: Karel Zak <kzak@xxxxxxxxxx>
---
 include/uapi/linux/magic.h    | 1 +
 include/uapi/linux/romfs_fs.h | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

diff --git a/include/uapi/linux/magic.h b/include/uapi/linux/magic.h
index 90b1681..c8b2b7e 100644
--- a/include/uapi/linux/magic.h
+++ b/include/uapi/linux/magic.h
@@ -24,6 +24,7 @@
 #define RAMFS_MAGIC		0x858458f6	/* some random number */
 #define TMPFS_MAGIC		0x01021994
 #define HUGETLBFS_MAGIC 	0x958458f6	/* some random number */
+#define ROMFS_MAGIC		0x7275
 #define SQUASHFS_MAGIC		0x73717368
 #define ECRYPTFS_SUPER_MAGIC	0xf15f
 #define EFS_SUPER_MAGIC		0x414A53
diff --git a/include/uapi/linux/romfs_fs.h b/include/uapi/linux/romfs_fs.h
index 5f57f93..cc77f59 100644
--- a/include/uapi/linux/romfs_fs.h
+++ b/include/uapi/linux/romfs_fs.h
@@ -3,13 +3,13 @@
 
 #include <linux/types.h>
 #include <linux/fs.h>
+#include <linux/magic.h>
 
 /* The basic structures of the romfs filesystem */
 
 #define ROMBSIZE BLOCK_SIZE
 #define ROMBSBITS BLOCK_SIZE_BITS
 #define ROMBMASK (ROMBSIZE-1)
-#define ROMFS_MAGIC 0x7275
 
 #define ROMFS_MAXFN 128
 
-- 
1.8.5.3

--
To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Ext4 Filesystem]     [Union Filesystem]     [Filesystem Testing]     [Ceph Users]     [Ecryptfs]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [Samba]     [Device Mapper]     [CEPH Development]
  Powered by Linux