Hi Gu, I agreed with Chao. It is more readable to use something like "is_read" instead of "rw". Thanks, 2013-12-19 (목), 09:23 +0800, Chao Yu: > Hi Gu, > > > -----Original Message----- > > From: Gu Zheng [mailto:guz.fnst@xxxxxxxxxxxxxx] > > Sent: Wednesday, December 18, 2013 6:29 PM > > To: Kim > > Cc: fsdevel; linux-kernel; f2fs > > Subject: [f2fs-dev] [PATCH] f2fs: move all the bio initialization into __bio_alloc > > > > Move all the bio initialization into __bio_alloc, and some minor cleanups are > > also added. > > Looks more neat! > > > @@ -178,17 +179,16 @@ void f2fs_submit_page_mbio(struct f2fs_sb_info *sbi, struct page *page, > > block_t blk_addr, struct f2fs_io_info *fio) > > { > > enum page_type btype = PAGE_TYPE_OF_BIO(fio->type); > > - struct block_device *bdev = sbi->sb->s_bdev; > > struct f2fs_bio_info *io; > > - int bio_blocks; > > + int rw = is_read_io(fio->rw); > > Maybe it's more neat to use 'is_read' to instead of 'rw'. > > Thanks > -- Jaegeuk Kim Samsung -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html