Dave Hansen wrote: > On 03/14/2013 10:50 AM, Kirill A. Shutemov wrote: > > --- a/include/linux/vm_event_item.h > > +++ b/include/linux/vm_event_item.h > > @@ -71,6 +71,8 @@ enum vm_event_item { PGPGIN, PGPGOUT, PSWPIN, PSWPOUT, > > THP_FAULT_FALLBACK, > > THP_COLLAPSE_ALLOC, > > THP_COLLAPSE_ALLOC_FAILED, > > + THP_WRITE_ALLOC, > > + THP_WRITE_FAILED, > > THP_SPLIT, > > THP_ZERO_PAGE_ALLOC, > > THP_ZERO_PAGE_ALLOC_FAILED, > > I think these names are a bit terse. It's certainly not _writes_ that > are failing and "THP_WRITE_FAILED" makes it sound that way. Right. s/THP_WRITE_FAILED/THP_WRITE_ALLOC_FAILED/ > Also, why do we need to differentiate these from the existing anon-hugepage > vm stats? The alloc_pages() call seems to be doing the exact same thing in > the end. Is one more likely to succeed than the other? Existing stats specify source of thp page: fault or collapse. When we allocate a new huge page with write(2) it's nither fault nor collapse. I think it's reasonable to introduce new type of event for that. -- Kirill A. Shutemov -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html