Hi, please what i'm doing wrong ? Consider the debugfs_create_by_name (fs/inode.c). I call this function two times, like this: struct dentry *de_mac; struct dentry *de_network; debugfs_create_by_name("ipv4", S_IFDIR, NULL, &de_mac, NULL); if (de_mac) { debugfs_create_by_name("tcp", S_IFDIR, de_mac, &de_network, NULL); if (de_mac->d_inode) printk("de_mac exists\n"); else printk("de_mac not exists\n"); if (de_network->d_inode) printk("de_network exists\n"); else printk("de_network not exists\n"); } Always de_mac exists, but in many times de_network is NULL. debugfs_create_by_name call lookup_one_len, and return a dentry, right ? In my mind both, de_mac and de_network should have a dentry->d_inode, right ? What i'm doing /thinking wrong ? I'm calling this inside a packet handler. Best Regards, fd. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html