On 12/02/2012 11:57 AM, Idan Kedar wrote: > On Fri, Nov 30, 2012 at 4:10 PM, Boaz Harrosh <bharrosh@xxxxxxxxxxx> wrote: <> >> err: >> - _unlock_pcol_pages(pcol, ret, WRITE); >> - pcol_free(pcol); >> + if (!pcol_copy) /* Failed before ownership transfer */ >> + pcol_copy = pcol; >> + _unlock_pcol_pages(pcol_copy, ret, WRITE); >> + pcol_free(pcol_copy); >> kfree(pcol_copy); >> >> return ret; >> -- >> 1.7.10.2.677.gb6bc67f >> > > I started with that implementation, but it seemed less readable to me. > I don't mind the readability, it is not that bad. But I do mind the extra local variable I'd rather not have it. (I hate it when two places have the same info, they get out of sync fast, I'd rather do with one) > On Fri, Nov 30, 2012 at 4:15 PM, Boaz Harrosh <bharrosh@xxxxxxxxxxx> wrote: >> On 11/30/2012 04:10 PM, Boaz Harrosh wrote: >> >> I forgot to ask do you need this for stable? >> >> Boaz > > nope. > Thanks Boaz -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html