On 08/28/2012 12:05 PM, Jan Kara wrote: >> +static inline u32 from_qown(struct user_namespace *user_ns, struct qown qown) >> +{ >> + switch (qown.type) { >> + case USRQUOTA: >> + return from_kuid(user_ns, qown.uid); >> + case GRPQUOTA: >> + return from_kgid(user_ns, qown.gid); >> + case XQM_PRJQUOTA: >> + return (user_ns == &init_user_ns) ? qown.prj : -1; >> + default: >> + BUG(); >> + } >> +} > I would like a bit more if the function somehow expressed in its name > that it returns id. id_from_qown() might be a bit too long given how often > it is used. qown2id() would be OK but it would be inconsistent with how > names of other functions you've added are formed. So I'm somewhat > undecided... > qown_id() > Honza -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html