On Mon 30-04-12 10:43:40, Christoph Hellwig wrote: > > +static void inode_wb_requeue(struct inode *inode, struct bdi_writeback *wb, > > + struct writeback_control *wbc) > > I'd just call this requeue_inode to fit the naming scheme in elsewhere > in the file. I'd also suggest adding a small top of function comment > explaining it. > > Otherwise looks good, > > Reviewed-by: Christoph Hellwig <hch@xxxxxx> OK, comment added: /* * Find proper writeback list for the inode depending on its current state and * possibly also change of its state while we were doing writeback. Here we * handle things such as livelock prevention or fairness of writeback among * inodes. This function can be called only by flusher thread - noone else * processes all inodes in writeback lists and requeueing inodes behind flusher * thread's back can have unexpected consequences. */ Honza -- Jan Kara <jack@xxxxxxx> SUSE Labs, CR -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html