--- On Mon, 12/9/11, Pavel Ivanov <paivanof@xxxxxxxxx> wrote: > On Mon, Sep 12, 2011 at 10:34 AM, > Christoph Hellwig <hch@xxxxxxxxxxxxx> > wrote: > > Does this patch fix your issues with large block > sizes? > > I'll be able to try it in the evening but meanwhile I have > some comments below. > > > > > > > Index: linux-2.6/fs/hfsplus/super.c > > > =================================================================== > > --- linux-2.6.orig/fs/hfsplus/super.c 2011-09-12 > 09:56:58.619988416 -0400 > > +++ linux-2.6/fs/hfsplus/super.c 2011-09-12 > 10:07:18.006651395 -0400 > > @@ -344,6 +344,7 @@ static int > hfsplus_fill_super(struct sup > > struct inode *root, *inode; > > struct qstr str; > > struct nls_table *nls = NULL; > > + u64 last_fs_block, last_fs_page; > > int err; > > > > err = -EINVAL; > > @@ -399,9 +400,13 @@ static int > hfsplus_fill_super(struct sup > > if (!sbi->rsrc_clump_blocks) > > sbi->rsrc_clump_blocks = 1; > > > > - err = > generic_check_addressable(sbi->alloc_blksz_shift, > > - > sbi->total_blocks); > > - if (err) { > > + err = -EFBIG; > > + last_fs_block = sbi->total_blocks - 1; > > + last_fs_page = (last_fs_block >> > sbi->alloc_blksz_shift) << > > + PAGE_CACHE_SHIFT; > > Did you mix left and right shifts here? Expression doesn't > make sense to me. > > Also I have a little concern about consistency in using > PAGE_CACHE_SHIFT and PAGE_SHIFT. hfsplus_read_wrapper() > limits visible > block size to PAGE_SIZE, not PAGE_CACHE_SIZE. And although > now they > are equal comment in linux/pagemap.h clearly says that > PAGE_CACHE_SIZE > can be bigger than PAGE_SIZE. Is it something that should > be fixed in > hfsplus_read_wrapper() ? > > > + > > + if ((last_fs_block > (sector_t)(~0ULL) > >> (sbi->alloc_blksz_shift - 9)) || > > Maybe this 9 should be extracted from here and > generic_check_addressable() into some macro? > > > + (last_fs_page > (pgoff_t)(~0ULL))) > { > > printk(KERN_ERR "hfs: > filesystem size too large.\n"); > > goto out_free_vhdr; > > } > > I 2nd that this is kind of ugly. The literal "9". How about abstracting this logic out to say, hfs_check_addressable()? -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html