Aneesh Kumar K.V <aneesh.kumar@xxxxxxxxxxxxxxxxxx> wrote: > + if ((error || is_sticky) && IS_RICHACL(inode) && > + !inode_permission(dir, mask & ~(MAY_WRITE | MAY_DELETE_CHILD)) && > + !inode_permission(inode, MAY_DELETE_SELF)) > + error = 0; This might be easier to follow if you used == 0 rather than !. The problem with ! is that it looks like: not_have inode_permission. I guess this is just one of the fun consequences of having 0 (false) meaning okay. David -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html