> /* > * A callback you can register to apply pressure to ageable caches. It's much more than just a single callback these days. > + * @scan_objects will be made from the current reclaim context. > */ > struct shrinker { > int (*shrink)(struct shrinker *, struct shrink_control *sc); > + long (*count_objects)(struct shrinker *, struct shrink_control *sc); > + long (*scan_objects)(struct shrinker *, struct shrink_control *sc); Is shrink_object really such a good name for this method? -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html