On Mon 09-05-11 12:04:45, Surbhi Palande wrote: > On 05/08/2011 11:24 AM, Marco Stornelli wrote: > >>+ error = jbd2_journal_flush(journal); > >>+ if (error>= 0) { > >>+ write_lock(&journal->j_state_lock); > >>+ journal->j_flags = journal->j_flags | JBD2_FROZEN; > > > >Better journal->j_flags |= JBD2_FROZEN; > > I was wondering why this is actually better than the longer form? Is > there any technical reason other than preference of coding style > here? It's just a coding style but that's kind of important as well. You don't have to employ your brain by checking whether the right hand side is the same as the left hand side in this case. So please use |=. Honza -- Jan Kara <jack@xxxxxxx> SUSE Labs, CR -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html