On Wed, Dec 15, 2010 at 01:16:52AM -0700, Andreas Dilger wrote: > On 2010-12-14, at 05:40, Nick Piggin wrote: > > +static inline void add_mnt_count(struct vfsmount *mnt, int n) > > +static inline void set_mnt_count(struct vfsmount *mnt, int n) > > +static inline void inc_mnt_count(struct vfsmount *mnt) > > +static inline void dec_mnt_count(struct vfsmount *mnt) > > +unsigned int count_mnt_count(struct vfsmount *mnt) > > Minor nit - it is easier to find these related functions via tag > completion if they are of the form "mnt_count_{add,set,inc,dec}" > and it would also be more consistent and easier to understand if > you rename count_mnt_count() to mnt_count_sum() or mnt_count_read(). > > This also follows the kernel naming convention much more closely > (e.g. atomic_{inc,dec,add,sub,set,read}(), mutex_{init,lock,unlock}(), > etc), which is normally of the form {type}_{action}. OK, I agree. > Yes, I see the other {inc,dec,count}_mnt_writers() functions > exist, but I'd prefer not to add more bad function names to > the kernel. Maybe a separate patch to clean up those names is > in order... I might have added those too :P Yes they should be consistent, so I'll rename them first. Thanks, Nick -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html