On 12/01/2010 10:57 AM, Charles Manning wrote: > Signed-off-by: Charles Manning <cdhmanning@xxxxxxxxx> > --- <snip> > diff --git a/fs/yaffs2/yportenv.h b/fs/yaffs2/yportenv.h > new file mode 100644 > index 0000000..8fd0da5 > --- /dev/null > +++ b/fs/yaffs2/yportenv.h > @@ -0,0 +1,91 @@ > +/* > + * YAFFS: Yet another Flash File System . A NAND-flash specific file system. > + * > + * Copyright (C) 2002-2010 Aleph One Ltd. > + * for Toby Churchill Ltd and Brightstar Engineering > + * > + * Created by Charles Manning <charles@xxxxxxxxxxxx> > + * > + * This program is free software; you can redistribute it and/or modify > + * it under the terms of the GNU Lesser General Public License version 2.1 as > + * published by the Free Software Foundation. > + * > + * Note: Only YAFFS headers are LGPL, YAFFS C code is covered by GPL. > + */ > + > +#ifndef __YPORTENV_LINUX_H__ > +#define __YPORTENV_LINUX_H__ > + > +#include <linux/version.h> > +#include <linux/kernel.h> > +#include <linux/mm.h> > +#include <linux/sched.h> > +#include <linux/string.h> > +#include <linux/slab.h> > +#include <linux/vmalloc.h> > +#include <linux/xattr.h> > +#include <linux/list.h> > +#include <linux/types.h> > +#include <linux/fs.h> > +#include <linux/stat.h> > +#include <linux/sort.h> > +#include <linux/bitops.h> > + > +#define YCHAR char > +#define YUCHAR unsigned char > +#define _Y(x) x > +#define yaffs_strcat(a, b) strcat(a, b) > +#define yaffs_strcpy(a, b) strcpy(a, b) > +#define yaffs_strncpy(a, b, c) strncpy(a, b, c) > +#define yaffs_strncmp(a, b, c) strncmp(a, b, c) > +#define yaffs_strnlen(s,m) strnlen(s,m) > +#define yaffs_sprintf sprintf > +#define yaffs_toupper(a) toupper(a) > +#define yaffs_sort(base, n, sz, cmp_fn) sort(base, n, sz, cmp_fn, NULL) > + > +#define Y_INLINE __inline__ > + > +#define YAFFS_LOSTNFOUND_NAME "lost+found" > +#define YAFFS_LOSTNFOUND_PREFIX "obj" > + > +#define YMALLOC(x) kmalloc(x, GFP_NOFS) > +#define YFREE(x) kfree(x) > +#define YMALLOC_ALT(x) vmalloc(x) > +#define YFREE_ALT(x) vfree(x) > +#define YMALLOC_DMA(x) YMALLOC(x) > + > +#define YYIELD() schedule() > +#define Y_DUMP_STACK() dump_stack() > + > +#define YAFFS_ROOT_MODE 0755 > +#define YAFFS_LOSTNFOUND_MODE 0700 > + > +#define Y_CURRENT_TIME CURRENT_TIME.tv_sec > +#define Y_TIME_CONVERT(x) (x).tv_sec > + > +#define yaffs_sum_cmp(x, y) ((x) == (y)) > +#define yaffs_strcmp(a, b) strcmp(a, b) You should try and remove the wrappers for as many of these as possible. I know the wrappers are there for portability to other operating systems, but for mainlining in Linux it makes the code more complex. > +#define TENDSTR "\n" > +#define TSTR(x) KERN_DEBUG x > +#define TCONT(x) x > +#define TOUT(p) printk p > + > +#define compile_time_assertion(assertion) \ > + ({ int x = __builtin_choose_expr(assertion, 0, (void)0); (void) x; }) Can you use BUILD_BUG_ON? > +#ifndef Y_DUMP_STACK > +#define Y_DUMP_STACK() do { } while (0) > +#endif Y_DUMP_STACK is defined above so this ifdef is useless? > +#ifndef YBUG > +#define YBUG() do {\ > + T(YAFFS_TRACE_BUG,\ > + (TSTR("==>> yaffs bug: " __FILE__ " %d" TENDSTR),\ > + __LINE__));\ > + Y_DUMP_STACK();\ > +} while (0) This macro name should possibly be changed since its name implies that it does the same thing as BUG(). ~Ryan -- Bluewater Systems Ltd - ARM Technology Solution Centre Ryan Mallon 5 Amuri Park, 404 Barbadoes St ryan@xxxxxxxxxxxxxxxx PO Box 13 889, Christchurch 8013 http://www.bluewatersys.com New Zealand Phone: +64 3 3779127 Freecall: Australia 1800 148 751 Fax: +64 3 3779135 USA 1800 261 2934 -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html