On Thu 21-10-10 12:48:12, Al Viro wrote: > On Thu, Oct 21, 2010 at 11:47:22AM +0200, Jan Kara wrote: > > The main fix in this patch is that truncate_setsize() should be called > > *before* not after filesystem truncated blocks. > > ITYM "contrary to what comment says, ..."; as it is, commit message alone > reads as if commit fixed the problem with actual code. OK. Attached is a version with updated changelog. Is it better? Honza
>From f237e25cae0b628fc81e4fa69b3b2a2ab2d0b086 Mon Sep 17 00:00:00 2001 From: Jan Kara <jack@xxxxxxx> Date: Thu, 21 Oct 2010 11:29:09 +0200 Subject: [PATCH] mm: Fix comment at truncate_setsize() The main fix in this patch is that, contrary to what the comment says, truncate_setsize() should be called *before* filesystem truncated blocks. CC: Christoph Hellwig <hch@xxxxxxxxxxxxx> Signed-off-by: Jan Kara <jack@xxxxxxx> --- mm/truncate.c | 11 +++++------ 1 files changed, 5 insertions(+), 6 deletions(-) diff --git a/mm/truncate.c b/mm/truncate.c index ba887bf..e13e535 100644 --- a/mm/truncate.c +++ b/mm/truncate.c @@ -545,13 +545,12 @@ EXPORT_SYMBOL(truncate_pagecache); * @inode: inode * @newsize: new file size * - * truncate_setsize updastes i_size update and performs pagecache - * truncation (if necessary) for a file size updates. It will be - * typically be called from the filesystem's setattr function when - * ATTR_SIZE is passed in. + * truncate_setsize updates i_size and performs pagecache truncation (if + * necessary) to @newsize. It will be typically be called from the filesystem's + * setattr function when ATTR_SIZE is passed in. * - * Must be called with inode_mutex held and after all filesystem - * specific block truncation has been performed. + * Must be called with inode_mutex held and before all filesystem specific + * block truncation has been performed. */ void truncate_setsize(struct inode *inode, loff_t newsize) { -- 1.6.4.2