On 08/06/10 18.14, Christoph Hellwig wrote: > The code dealing with bdi_work->state and completion of a bdi_work is a > major mess currently. This patch makes sure we directly use one set of > flags to deal with it, and use it consistently, which means: > > - always notify about completion from the rcu callback. We only ever > wait for it from on-stack callers, so this simplification does not > even cause a theoretical slowdown currently. It also makes sure we > don't miss out on the notification if we ever add other callers to > wait for it. It's still more costly to actually do the rcu callback, but I guess it's not too big of a deal. > - make earlier completion notification depending on the on-stack > allocation, not the sync mode. If we introduce new callers that > want to do WB_SYNC_NONE writeback from on-stack callers this will > be nessecary. > > Also rename bdi_wait_on_work_clear to bdi_wait_on_work_done and inline > a few small functions into their only caller to make the code > understandable. Looks good to me. -- Jens Axboe -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html