On Thu, 2010-05-06 at 11:47 -0700, Davide Libenzi wrote: > Since we already have __add_wait_queue(), __add_wait_queue_tail() and > __remove_wait_queue() (which all means "locked"), and while I agree in > having the exclusive-add wrapped into a function, I much better prefer a: > > static inline void __add_wait_queue_excl(wait_queue_head_t *head, > wait_queue_t *new) > { > new->flags |= WQ_FLAG_EXCLUSIVE; > __add_wait_queue(head, new); > } > > The patch you posted introduces a different naming, which leaves all the > other __*() untouched, and wraps the already one-liner __remove_wait_queue() > with yet another one-liner. I concur, I always get confused by the _locked postfix (and its more typing). Also, it goes against the lock data not code paradigm. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html