On Mon, Feb 03, 2025 at 10:43:07AM +0100, Christoph Hellwig wrote: > Allocate the bio from the bioset provided in iomap_read_folio_ops. > If no bioset is provided, fs_bio_set is used which is the standard > bioset for filesystems. It feels weird to have an 'ops' that contains a bioset rather than a function pointer. Is there a better name we could be using? ctx seems wrong because it's not a per-op struct. > +++ b/include/linux/iomap.h > @@ -311,6 +311,12 @@ struct iomap_read_folio_ops { > */ > void (*submit_io)(struct inode *inode, struct bio *bio, > loff_t file_offset); > + > + /* > + * Optional, allows filesystem to specify own bio_set, so new bio's > + * can be allocated from the provided bio_set. > + */ > + struct bio_set *bio_set; > };