I will read this series later, but I see nothing wrong after a quick glance. Minor nit below... On 03/04, Christian Brauner wrote: > > Record the exit code and cgroupid in do_exit() ^^^^^^^^^^^^ this is no longer true. In release_task(). > @@ -254,6 +255,7 @@ void release_task(struct task_struct *p) > write_lock_irq(&tasklist_lock); > ptrace_release_task(p); > thread_pid = get_pid(p->thread_pid); > + pidfs_exit(p); > __exit_signal(p); And the next patch rightly moves pidfs_exit() up outside of tasklist. Why not call it before write_lock_irq(&tasklist_lock) from the very beginning? Oleg.