Re: [PATCH v1 02/17] mm: factor out large folio handling from folio_nr_pages() into folio_large_nr_pages()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Aug 29, 2024 at 06:56:05PM +0200, David Hildenbrand wrote:
> Let's factor it out into a simple helper function. This helper will
> also come in handy when working with code where we know that our
> folio is large.
> 
> Make use of it in internal.h and mm.h, where applicable.
> 
> While at it, let's consistently return a "long" value from all these
> similar functions. Note that we cannot use "unsigned int" (even though
> _folio_nr_pages is of that type), because it would break some callers
> that do stuff like "-folio_nr_pages()". Both "int" or "unsigned long"
> would work as well.
> 
> Signed-off-by: David Hildenbrand <david@xxxxxxxxxx>
> ---
>  include/linux/mm.h | 27 ++++++++++++++-------------
>  mm/internal.h      |  2 +-
>  2 files changed, 15 insertions(+), 14 deletions(-)
> 
> diff --git a/include/linux/mm.h b/include/linux/mm.h
> index 3c6270f87bdc3..fa8b6ce54235c 100644
> --- a/include/linux/mm.h
> +++ b/include/linux/mm.h
> @@ -1076,6 +1076,15 @@ static inline unsigned int folio_large_order(const struct folio *folio)
>  	return folio->_flags_1 & 0xff;
>  }
>  
> +static inline long folio_large_nr_pages(const struct folio *folio)
> +{
> +#ifdef CONFIG_64BIT
> +	return folio->_folio_nr_pages;
> +#else
> +	return 1L << folio_large_order(folio);
> +#endif
> +}
> +

Maybe it would be cleaner to move #ifdef outside of the function?

Otherwise:

Reviewed-by: Kirill A. Shutemov <kirill.shutemov@xxxxxxxxxxxxxxx>

-- 
  Kiryl Shutsemau / Kirill A. Shutemov




[Index of Archives]     [Linux Ext4 Filesystem]     [Union Filesystem]     [Filesystem Testing]     [Ceph Users]     [Ecryptfs]     [NTFS 3]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [NTFS 3]     [Samba]     [Device Mapper]     [CEPH Development]

  Powered by Linux