It's not a good practice to leave a definition between 'switch' and the its first label. Move it out of the switch block. Signed-off-by: WANG Cong <amwang@xxxxxxxxxx> Cc: Matthew Wilcox <matthew@xxxxxx> Cc: Alexander Viro <viro@xxxxxxxxxxxxxxxxxx> Cc: Jonathan Corbet <corbet@xxxxxxx> Cc: Oleg Nesterov <oleg@xxxxxxxxxx> Cc: Christoph Hellwig <hch@xxxxxx> --- diff --git a/fs/fcntl.c b/fs/fcntl.c index 2cf93ec..23b0238 100644 --- a/fs/fcntl.c +++ b/fs/fcntl.c @@ -514,12 +514,12 @@ static void send_sigio_to_task(struct task_struct *p, * sure we read it once and use the same value throughout. */ int signum = ACCESS_ONCE(fown->signum); + siginfo_t si; if (!sigio_perm(p, fown, signum)) return; switch (signum) { - siginfo_t si; default: /* Queue a rt signal with the appropriate fd as its value. We use SI_SIGIO as the source, not -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html