On Thu, 22 Aug 2024 at 01:25, Joanne Koong <joannelkoong@xxxxxxxxx> wrote: > > Tidy up the error paths in fuse_writepages_fill() and > fuse_writepage_locked() to be easier to read / less cluttered. > > No functional changes added. > > Signed-off-by: Joanne Koong <joannelkoong@xxxxxxxxx> > --- > fs/fuse/file.c | 21 ++++++++++++--------- > 1 file changed, 12 insertions(+), 9 deletions(-) > > diff --git a/fs/fuse/file.c b/fs/fuse/file.c > index fe8ae19587fb..0a3a92ef645d 100644 > --- a/fs/fuse/file.c > +++ b/fs/fuse/file.c > @@ -2098,16 +2098,19 @@ static int fuse_writepage_locked(struct folio *folio) > struct fuse_args_pages *ap; > struct folio *tmp_folio; > struct fuse_file *ff; > - int error = -ENOMEM; > + int error; > > tmp_folio = folio_alloc(GFP_NOFS | __GFP_HIGHMEM, 0); > - if (!tmp_folio) > + if (!tmp_folio) { > + error = -ENOMEM; > goto err; > + } Same comment as previous patch. Thanks, Miklos