On Fri 02-08-24 22:54:55, Joel Savitz wrote: > Cc: Alexander Viro <viro@xxxxxxxxxxxxxxxxxx> > Cc: Christian Brauner <brauner@xxxxxxxxxx> > Cc: Jan Kara <jack@xxxxxxx> > Cc: linux-fsdevel@xxxxxxxxxxxxxxx > > The comment on EXPORT_SYMBOL(close_fd) was added in commit 2ca2a09d6215 > ("fs: add ksys_close() wrapper; remove in-kernel calls to sys_close()"), > before commit 8760c909f54a ("file: Rename __close_fd to close_fd and remove > the files parameter") gave the function its current name, however commit > 1572bfdf21d4 ("file: Replace ksys_close with close_fd") removes the > referenced caller entirely, obsoleting this comment. > > Signed-off-by: Joel Savitz <jsavitz@xxxxxxxxxx> Looks good. Feel free to add: Reviewed-by: Jan Kara <jack@xxxxxxx> Honza > --- > fs/file.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/fs/file.c b/fs/file.c > index a3b72aa64f11..cfc58b782bc4 100644 > --- a/fs/file.c > +++ b/fs/file.c > @@ -676,7 +676,7 @@ int close_fd(unsigned fd) > > return filp_close(file, files); > } > -EXPORT_SYMBOL(close_fd); /* for ksys_close() */ > +EXPORT_SYMBOL(close_fd); > > /** > * last_fd - return last valid index into fd table > -- > 2.45.2 > -- Jan Kara <jack@xxxxxxxx> SUSE Labs, CR