Re: [PATCH 2/2] fuse: add support for no forget requests

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Jul 26, 2024 at 11:40:17AM -0400, Josef Bacik wrote:
> On Fri, Jul 26, 2024 at 04:37:52PM +0800, yangyun wrote:
> > FUSE_FORGET requests are not used if the fuse file system does not
> > implement the forget operation in userspace (e.g., fuse file system
> > does not cache any inodes).
> > 
> > However, the kernel is invisible to the userspace implementation and
> > always sends FUSE_FORGET requests, which can lead to performance
> > degradation because of useless contex switch and memory copy in some
> > cases (e.g., many inodes are evicted from icache which was described
> > in commit 07e77dca8a1f ("fuse: separate queue for FORGET requests")).
> > 
> > Just like 'no_interrupt' in 'struct fuse_conn', we add 'no_forget'.
> > But since FUSE_FORGET request does not have a reply from userspce,
> > we can not use ENOSYS to reflect the 'no_forget' assignment. So add
> > the FUSE_NO_FORGET_SUPPORT init flag.
> > 
> > Besides, if no_forget is enabled, 'nlookup' in 'struct fuse_inode'
> > does not used and its value change can be disabled which are protected
> > by spin_lock to reduce lock contention.
> > 
> > Signed-off-by: yangyun <yangyun50@xxxxxxxxxx>
> > ---
> >  fs/fuse/dev.c             |  6 ++++++
> >  fs/fuse/dir.c             |  4 +---
> >  fs/fuse/fuse_i.h          | 24 ++++++++++++++++++++++++
> >  fs/fuse/inode.c           | 10 +++++-----
> >  fs/fuse/readdir.c         |  8 ++------
> >  include/uapi/linux/fuse.h |  3 +++
> >  6 files changed, 41 insertions(+), 14 deletions(-)
> > 
> > diff --git a/fs/fuse/dev.c b/fs/fuse/dev.c
> > index 932356833b0d..10890db9426b 100644
> > --- a/fs/fuse/dev.c
> > +++ b/fs/fuse/dev.c
> > @@ -238,6 +238,9 @@ void fuse_queue_forget(struct fuse_conn *fc, struct fuse_forget_link *forget,
> >  {
> >  	struct fuse_iqueue *fiq = &fc->iq;
> >  
> > +	if (fc->no_forget)
> > +		return;
> > +
> >  	forget->forget_one.nodeid = nodeid;
> >  	forget->forget_one.nlookup = nlookup;
> >  
> > @@ -257,6 +260,9 @@ void fuse_force_forget(struct fuse_mount *fm, u64 nodeid)
> >  	struct fuse_forget_in inarg;
> >  	FUSE_ARGS(args);
> >  
> > +	if (fm->fc->no_forget)
> > +		return;
> > +
> >  	memset(&inarg, 0, sizeof(inarg));
> >  	inarg.nlookup = 1;
> >  	args.opcode = FUSE_FORGET;
> > diff --git a/fs/fuse/dir.c b/fs/fuse/dir.c
> > index 6bfb3a128658..833225ed1d4f 100644
> > --- a/fs/fuse/dir.c
> > +++ b/fs/fuse/dir.c
> > @@ -236,9 +236,7 @@ static int fuse_dentry_revalidate(struct dentry *entry, unsigned int flags)
> >  				fuse_force_forget(fm, outarg.nodeid);
> >  				goto invalid;
> >  			}
> > -			spin_lock(&fi->lock);
> > -			fi->nlookup++;
> > -			spin_unlock(&fi->lock);
> > +			fuse_nlookup_inc_if_enabled(fm->fc, fi);
> >  		}
> >  		if (ret == -ENOMEM || ret == -EINTR)
> >  			goto out;
> > diff --git a/fs/fuse/fuse_i.h b/fs/fuse/fuse_i.h
> > index b9a5b8ec0de5..924d6b0ad700 100644
> > --- a/fs/fuse/fuse_i.h
> > +++ b/fs/fuse/fuse_i.h
> > @@ -860,6 +860,9 @@ struct fuse_conn {
> >  	/** Passthrough support for read/write IO */
> >  	unsigned int passthrough:1;
> >  
> > +	/** Do not send FORGET request */
> > +	unsigned int no_forget:1;
> > +
> >  	/** Maximum stack depth for passthrough backing files */
> >  	int max_stack_depth;
> >  
> > @@ -1029,6 +1032,27 @@ static inline void fuse_sync_bucket_dec(struct fuse_sync_bucket *bucket)
> >  	rcu_read_unlock();
> >  }
> >  
> > +static inline void fuse_nlookup_inc_if_enabled(struct fuse_conn *fc, struct fuse_inode *fi)
> > +{
> > +	if (fc->no_forget)
> > +		return;
> > +
> > +	spin_lock(&fi->lock);
> > +	fi->nlookup++;
> > +	spin_unlock(&fi->lock);
> > +}
> > +
> > +static inline void fuse_nlookup_dec_if_enabled(struct fuse_conn *fc, struct fuse_inode *fi)
> > +{
> > +	if (fc->no_forget)
> > +		return;
> > +
> > +	spin_lock(&fi->lock);
> > +	fi->nlookup--;
> > +	spin_lock(&fi->lock);
> > +}
> 
> This naming scheme is overly verbose, you can simply have
> 
> fuse_inc_nlookup()
> fuse_dec_nlookup()

Thanks for your advice.
I will modify this in the next version. 

> 
> Thanks,
> 
> Josef




[Index of Archives]     [Linux Ext4 Filesystem]     [Union Filesystem]     [Filesystem Testing]     [Ceph Users]     [Ecryptfs]     [NTFS 3]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [NTFS 3]     [Samba]     [Device Mapper]     [CEPH Development]

  Powered by Linux