Re: [PATCH v6 0/3] Clean up usage of rt_task()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 06/10/24 20:20, Qais Yousef wrote:
> Make rt_task() return true only for RT class and add new realtime_task() to
> return true for RT and DL classes to avoid some confusion the old API can
> cause.

I am not aware of any pending review comments for this series. Is it ready to
be picked up?


Thanks!

--
Qais Yousef

> 
> No functional changes intended in patch 1. Patch 2 cleans up the return type as
> suggested by Steve. Patch 3 uses rt_or_dl() instead of 'realtime' as suggested
> by Daniel. As the name was debatable, I'll leave up to the maintainers to pick
> their preference.
> 
> Changes since v5:
> 
> 	* Added a new patch to s/realtime/rt_or_dl/ as suggested by Daniel.
> 	* Added Reviewed-bys.
> 
> Changes since v4:
> 
> 	* Simplify return of rt/realtime_prio() as the explicit true/false was
> 	  not necessary.
> 
> Changes since v3:
> 
> 	* Make sure the 'new' bool functions return true/false instead of 1/0.
> 	* Drop patch 2 about hrtimer usage of realtime_task() as ongoing
> 	  discussion on v1 indicates its scope outside of this simple cleanup.
> 
> Changes since v2:
> 
> 	* Fix one user that should use realtime_task() but remained using
> 	  rt_task() (Sebastian)
> 	* New patch to convert all hrtimer users to use realtime_task_policy()
> 	  (Sebastian)
> 	* Add a new patch to convert return type to bool (Steve)
> 	* Rebase on tip/sched/core and handle a conflict with code shuffle to
> 	  syscalls.c
> 	* Add Reviewed-by Steve
> 
> Changes since v1:
> 
> 	* Use realtime_task_policy() instead task_has_realtime_policy() (Peter)
> 	* Improve commit message readability about replace some rt_task()
> 	  users.
> 
> v1 discussion: https://lore.kernel.org/lkml/20240514234112.792989-1-qyousef@xxxxxxxxxxx/
> v2 discussion: https://lore.kernel.org/lkml/20240515220536.823145-1-qyousef@xxxxxxxxxxx/
> v3 discussion: https://lore.kernel.org/lkml/20240527234508.1062360-1-qyousef@xxxxxxxxxxx/
> v4 discussion: https://lore.kernel.org/lkml/20240601213309.1262206-1-qyousef@xxxxxxxxxxx/
> v5 discussion: https://lore.kernel.org/lkml/20240604144228.1356121-1-qyousef@xxxxxxxxxxx/
> 
> Qais Yousef (3):
>   sched/rt: Clean up usage of rt_task()
>   sched/rt, dl: Convert functions to return bool
>   sched/rt: Rename realtime_{prio, task}() to rt_or_dl_{prio, task}()
> 
>  fs/bcachefs/six.c                 |  2 +-
>  fs/select.c                       |  2 +-
>  include/linux/ioprio.h            |  2 +-
>  include/linux/sched/deadline.h    | 14 ++++++-------
>  include/linux/sched/prio.h        |  1 +
>  include/linux/sched/rt.h          | 33 +++++++++++++++++++++++++------
>  kernel/locking/rtmutex.c          |  4 ++--
>  kernel/locking/rwsem.c            |  4 ++--
>  kernel/locking/ww_mutex.h         |  2 +-
>  kernel/sched/core.c               |  4 ++--
>  kernel/sched/syscalls.c           |  2 +-
>  kernel/time/hrtimer.c             |  6 +++---
>  kernel/trace/trace_sched_wakeup.c |  2 +-
>  mm/page-writeback.c               |  4 ++--
>  mm/page_alloc.c                   |  2 +-
>  15 files changed, 53 insertions(+), 31 deletions(-)
> 
> -- 
> 2.34.1
> 




[Index of Archives]     [Linux Ext4 Filesystem]     [Union Filesystem]     [Filesystem Testing]     [Ceph Users]     [Ecryptfs]     [NTFS 3]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [NTFS 3]     [Samba]     [Device Mapper]     [CEPH Development]

  Powered by Linux