On Mon, Jun 03, 2024 at 07:24:03PM +0000, Bernd Schubert wrote: > void *vmalloc_node(unsigned long size, int node) > { > return __vmalloc_node(size, 1, GFP_KERNEL, node, > __builtin_return_address(0)); > } > > > > > If we wanted to avoid another export, shouldn't we better rename > vmalloc_user to vmalloc_node_user, add the node argument and change > all callers? > > Anyway, I will send the current patch separately to linux-mm and will ask > if it can get merged before the fuse patches. Well, the GFP flags exist to avoid needing a gazillion of variants of everything build around the page allocator. For vmalloc we can't, as Kent rightly said, support GFP_NOFS and GFP_NOIO and need to use the scopes instead, and we should warn about that (which __vmalloc doesn't and could use some fixes for).