On Wed, May 15, 2024 at 01:06:13PM +0100 Qais Yousef wrote: > On 05/15/24 07:20, Phil Auld wrote: > > On Wed, May 15, 2024 at 10:32:38AM +0200 Peter Zijlstra wrote: > > > On Tue, May 14, 2024 at 07:58:51PM -0400, Phil Auld wrote: > > > > > > > > Hi Qais, > > > > > > > > On Wed, May 15, 2024 at 12:41:12AM +0100 Qais Yousef wrote: > > > > > rt_task() checks if a task has RT priority. But depends on your > > > > > dictionary, this could mean it belongs to RT class, or is a 'realtime' > > > > > task, which includes RT and DL classes. > > > > > > > > > > Since this has caused some confusion already on discussion [1], it > > > > > seemed a clean up is due. > > > > > > > > > > I define the usage of rt_task() to be tasks that belong to RT class. > > > > > Make sure that it returns true only for RT class and audit the users and > > > > > replace them with the new realtime_task() which returns true for RT and > > > > > DL classes - the old behavior. Introduce similar realtime_prio() to > > > > > create similar distinction to rt_prio() and update the users. > > > > > > > > I think making the difference clear is good. However, I think rt_task() is > > > > a better name. We have dl_task() still. And rt tasks are things managed > > > > by rt.c, basically. Not realtime.c :) I know that doesn't work for deadline.c > > > > and dl_ but this change would be the reverse of that pattern. > > > > > > It's going to be a mess either way around, but I think rt_task() and > > > dl_task() being distinct is more sensible than the current overlap. > > > > > > > Yes, indeed. > > > > My point was just to call it rt_task() still. > > It is called rt_task() still. I just added a new realtime_task() to return true > for RT and DL. rt_task() will return true only for RT now. > > How do you see this should be done instead? I'm not seeing the problem. > Right, sorry. I misread your commit message completely and then all the places where you changed rt_task() to realtime_task() fit my misreading. rt_task() means rt class and realtime_task does what rt_task() used to do. That's how I would do it, too :) (Re) Reviewed-by: Phil Auld <pauld@xxxxxxxxxx> Cheers, Phil --