Hi Eric! Thanks for the conversion! On Fri 01-03-24 16:56:41, Eric Sandeen wrote: > -static int isofs_remount(struct super_block *sb, int *flags, char *data) > +static int iso9660_reconfigure(struct fs_context *fc) ^^^ Why this renaming? Practically all the function have isofs prefix, not iso9660 so I'd prefer to keep it. Similarly with other vars defined below. If anything, I'd rename struct iso9660_options to struct isofs_options... > { > - sync_filesystem(sb); > - if (!(*flags & SB_RDONLY)) > + sync_filesystem(fc->root->d_sb); > + if (!(fc->sb_flags & SB_RDONLY) & SB_RDONLY) ^^^ What's this about? Otherwise the patch looks good to me! Honza -- Jan Kara <jack@xxxxxxxx> SUSE Labs, CR