On 2/21/24 20:40, Suren Baghdasaryan wrote: > > +static inline void alloc_tag_sub(union codetag_ref *ref, size_t bytes) > +{ > + __alloc_tag_sub(ref, bytes); > +} > + > +static inline void alloc_tag_sub_noalloc(union codetag_ref *ref, size_t bytes) > +{ > + __alloc_tag_sub(ref, bytes); > +} > + Nit: just notice these are now the same and maybe you could just drop both wrappers and rename __alloc_tag_sub to alloc_tag_sub?