On Mon, Aug 17, 2009 at 06:41:44PM +0200, Nick Piggin wrote: > Just wonder what you think of this for an updated patch. Main changes > since last time are changelog changed, more comments, and addition of > simple_setattr and inode_set_attributes. I was going to leave > simple_setattr for later, but now I found when converting the simple > filesystem ramfs that we basically need it anyway. > > inode_set_attributes is also following your suggestion and if we use > it then we don't have to do that masking away ATTR_SIZE then calling > inode_setattr that you didn't like (and I agree with). I like this a lot. But please change the inode_set_attributes name, it's awkward and totally falls out of the scheme. It defintively should be <something>_setattr. Not sure about what to use for the <something>. Maybe just generic_setattr, mirroring generic_getattr? Btw, one idea on how to avoid having to touch all the begin_write/end_write/direct_IO instances: What about passing another callback to them, in addition to the get_blocks also a trim_blocks which we call to trim blocks over i_size. That would be the old ->truncate minus the block_truncate_page. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html