On Thu 30-11-23 13:49:09, Christian Brauner wrote: > The naming is actively misleading since we switched to > SLAB_TYPESAFE_BY_RCU. rcu_head is #define callback_head. Use > callback_head directly and rename f_rcuhead to f_tw. > > Signed-off-by: Christian Brauner <brauner@xxxxxxxxxx> Nice. Feel free to add: Reviewed-by: Jan Kara <jack@xxxxxxx> Honza > --- > fs/file_table.c | 6 +++--- > include/linux/fs.h | 2 +- > 2 files changed, 4 insertions(+), 4 deletions(-) > > diff --git a/fs/file_table.c b/fs/file_table.c > index 6deac386486d..78614204ef2c 100644 > --- a/fs/file_table.c > +++ b/fs/file_table.c > @@ -407,7 +407,7 @@ static void delayed_fput(struct work_struct *unused) > > static void ____fput(struct callback_head *work) > { > - __fput(container_of(work, struct file, f_rcuhead)); > + __fput(container_of(work, struct file, f_tw)); > } > > /* > @@ -438,8 +438,8 @@ void fput(struct file *file) > return; > } > if (likely(!in_interrupt() && !(task->flags & PF_KTHREAD))) { > - init_task_work(&file->f_rcuhead, ____fput); > - if (!task_work_add(task, &file->f_rcuhead, TWA_RESUME)) > + init_task_work(&file->f_tw, ____fput); > + if (!task_work_add(task, &file->f_tw, TWA_RESUME)) > return; > /* > * After this task has run exit_task_work(), > diff --git a/include/linux/fs.h b/include/linux/fs.h > index f171505940ff..d23a886df8fa 100644 > --- a/include/linux/fs.h > +++ b/include/linux/fs.h > @@ -992,7 +992,7 @@ static inline int ra_has_index(struct file_ra_state *ra, pgoff_t index) > struct file { > union { > struct llist_node f_llist; > - struct rcu_head f_rcuhead; > + struct callback_head f_tw; > unsigned int f_iocb_flags; > }; > > > -- > 2.42.0 > -- Jan Kara <jack@xxxxxxxx> SUSE Labs, CR