On Thu, Jul 02, 2009 at 09:22:25AM +0200, Nick Piggin wrote: > > Looking at your patch I really like that vmtruncate now really just > > does what it's name claims to - truncate the VM-information about > > the file (well, and the file size). I'm not so happy about > > still keeping the two level setattr/truncate indirection. > > In my patch series, i_size update eventually is moved out to the > filesystem too, and vmtruncate just is renamed to truncate_pagecache > (vmtruncate is not such a bad name, but rename will nicely break > unconverted modules). Good, that's a much better calling and naming convention. > > But instead of folding truncate into setattr I wonder if we should > > just add a new ->setsize (aka new trunacte) methodas a top-level > > entry point instead of ->setattr with ATTR_SIZE given that size > > changes don't have much in common with the reset of ->setattr. > > OK that would be possible and makes sense I guess. The new truncate > which returns error could basically be renamed in-place. Shall we > continue to give ATTR_SIZE to setattr, or take that out completely? > I guess truncate can be considered special because it operates on > data not only metadata. > > Looks like ->setsize would need a flag for ATTR_OPEN too? Any others? > I'll do a bit of an audit when I get around to it... In the end ATTR_SIZE should not be passed to ->setattr anymore, and ->setsize should become mandatory. For the transition I would recommend calling ->setsize if present else fall back to the current way. That way we can migreate one filesystem per patch to the new scheme. I would suggest giving the flags to ->setsize their own namespace with two flags so far SETSIZE_FTRUNCATE (need to update the file size and have a file struct available) and SETSIZE_OPEN for the ATTR_OPEN case. That beeing said I reallye hate the conditiona file argument for ftrunctate (currently hidden inside struct iattr), maybe we're better off having am optional int (*ftruncate)(struct file *) method for those filesystems that need it, with a fallback to ->setsize. And yeah, maybe ->setsize might better be left as ->truncate, but if we want a nicely bisectable migration we'd have to rename the old truncate to e.g. ->old_truncate before. That's probably worth having the better naming in the end. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html