On Tue, Aug 29, 2023 at 06:58:47PM -0400, Jeff Layton wrote: > On Tue, 2023-08-29 at 23:44 +0100, Al Viro wrote: > > On Tue, Jul 25, 2023 at 10:58:14AM -0400, Jeff Layton wrote: > > > generic_fillattr just fills in the entire stat struct indiscriminately > > > today, copying data from the inode. There is at least one attribute > > > (STATX_CHANGE_COOKIE) that can have side effects when it is reported, > > > and we're looking at adding more with the addition of multigrain > > > timestamps. > > > > > > Add a request_mask argument to generic_fillattr and have most callers > > > just pass in the value that is passed to getattr. Have other callers > > > (e.g. ksmbd) just pass in STATX_BASIC_STATS. Also move the setting of > > > STATX_CHANGE_COOKIE into generic_fillattr. > > > > Out of curiosity - how much PITA would it be to put request_mask into > > kstat? Set it in vfs_getattr_nosec() (and those get_file_..._info() > > on smbd side) and don't bother with that kind of propagation boilerplate > > - just have generic_fillattr() pick it there... > > > > Reduces the patchset size quite a bit... > > It could be done. To do that right, I think we'd want to drop > request_mask from the ->getattr prototype as well and just have > everything use the mask in the kstat. > > I don't think it'd reduce the size of the patchset in any meaningful > way, but it might make for a more sensible API over the long haul. ->getattr() prototype change would be decoupled from that - for your patchset you'd only need the field addition + setting in vfs_getattr_nosec() (and possibly in ksmbd), with the remainders of both series being independent from each other. What I suggest is branchpoint -> field addition (trivial commit) -> argument removal | V your series, starting with "use stat->request_mask in generic_fillattr()" Total size would be about the same, but it would be easier to follow the less trivial part of that. Nothing in your branch downstream of that touches any ->getattr() instances, so it should have no conflicts with the argument removal side of things.