On Thu, 24 Aug 2023 at 17:06, Bernd Schubert <bschubert@xxxxxxx> wrote: > > This is just a preparation to avoid code duplication in the next > commit. > > Cc: Hao Xu <howeyxu@xxxxxxxxxxx> > Cc: Miklos Szeredi <miklos@xxxxxxxxxx> > Cc: Dharmendra Singh <dsingh@xxxxxxx> > Signed-off-by: Bernd Schubert <bschubert@xxxxxxx> > --- > fs/fuse/file.c | 36 ++++++++++++++++++++++-------------- > 1 file changed, 22 insertions(+), 14 deletions(-) > > diff --git a/fs/fuse/file.c b/fs/fuse/file.c > index b1b9f2b9a37d..a16f9b6888de 100644 > --- a/fs/fuse/file.c > +++ b/fs/fuse/file.c > @@ -1298,6 +1298,27 @@ static ssize_t fuse_perform_write(struct kiocb *iocb, struct iov_iter *ii) > return res; > } > > +static bool fuse_direct_write_extending_i_size(struct kiocb *iocb, > + struct iov_iter *iter) > +{ > + struct inode *inode = file_inode(iocb->ki_filp); > + > + return iocb->ki_pos + iov_iter_count(iter) > i_size_read(inode); > +} The name suggests that this helper test for write as well as for direct IO. It does neither, instead it just checks whether the I/O reaches past EOF. So I'd name it e.g. io_past_eof(). > +/* > + * @return true if an exclusive lock direct IO writes is needed > + */ > +static bool fuse_dio_wr_exclusive_lock(struct kiocb *iocb, struct iov_iter *from) > +{ > + struct file *file = iocb->ki_filp; > + struct fuse_file *ff = file->private_data; > + > + return !(ff->open_flags & FOPEN_PARALLEL_DIRECT_WRITES) || > + iocb->ki_flags & IOCB_APPEND || > + fuse_direct_write_extending_i_size(iocb, from); > +} > + Now that this is a function it's possible to rewrite it as a series of single-condition ifs. Thanks, Miklos