On Thu, 1 Jun 2023 at 14:01, Bernd Schubert <bschubert@xxxxxxx> wrote: > > On 6/1/23 13:50, Miklos Szeredi wrote: > > On Thu, 1 Jun 2023 at 13:17, Bernd Schubert <bschubert@xxxxxxx> wrote: > >> > >> Hi Miklos, > >> > >> On 5/19/22 11:39, Miklos Szeredi wrote: > >>> On Tue, 17 May 2022 at 12:08, Dharmendra Singh <dharamhans87@xxxxxxxxx> wrote: > >>>> > >>>> In FUSE, as of now, uncached lookups are expensive over the wire. > >>>> E.g additional latencies and stressing (meta data) servers from > >>>> thousands of clients. These lookup calls possibly can be avoided > >>>> in some cases. Incoming three patches address this issue. > >>>> > >>>> > >>>> Fist patch handles the case where we are creating a file with O_CREAT. > >>>> Before we go for file creation, we do a lookup on the file which is most > >>>> likely non-existent. After this lookup is done, we again go into libfuse > >>>> to create file. Such lookups where file is most likely non-existent, can > >>>> be avoided. > >>> > >>> I'd really like to see a bit wider picture... > >>> > >>> We have several cases, first of all let's look at plain O_CREAT > >>> without O_EXCL (assume that there were no changes since the last > >>> lookup for simplicity): > >>> > >>> [not cached, negative] > >>> ->atomic_open() > >>> LOOKUP > >>> CREATE > >>> > >> > >> [...] > >> > >>> [not cached] > >>> ->atomic_open() > >>> OPEN_ATOMIC > >> > >> new patch version is eventually going through xfstests (and it finds > >> some issues), but I have a question about wording here. Why > >> "OPEN_ATOMIC" and not "ATOMIC_OPEN". Based on your comment @Dharmendra > >> renamed all functions and this fuse op "open atomic" instead of "atomic > >> open" - for my non native English this sounds rather weird. At best it > >> should be "open atomically"? > > > > FUSE_OPEN_ATOMIC is a specialization of FUSE_OPEN. Does that explain > > my thinking? > > Yeah, just the vfs function is also called atomic_open. We now have > > > static int fuse_atomic_open(struct inode *dir, struct dentry *entry, > struct file *file, unsigned flags, > umode_t mode) > { > struct fuse_conn *fc = get_fuse_conn(dir); > > if (fc->no_open_atomic) > return fuse_open_nonatomic(dir, entry, file, flags, mode); > else > return fuse_open_atomic(dir, entry, file, flags, mode); > } > > > Personally I would use something like _fuse_atomic_open() and > fuse_create_open() (instead of fuse_open_nonatomic). The order of "open > atomic" also made it into libfuse and comments - it just sounds a bit > weird ;) I have to live with it, if you prefer it like this. I'd prefer FUSE_OPEN_ATOMIC for the API, but I don't care about function names, as long as the purpose is clear. Thanks, Miklos