On Thu, May 25, 2023 at 05:48:20PM -0400, Kent Overstreet wrote: > This reimplements bio_for_each_folio_all() on top of the newly-reworked > bvec_iter_all, and since it's now trivial we also provide > bio_for_each_folio. > > Signed-off-by: Kent Overstreet <kent.overstreet@xxxxxxxxx> > Cc: Matthew Wilcox <willy@xxxxxxxxxxxxx> > Cc: linux-block@xxxxxxxxxxxxxxx > --- > fs/crypto/bio.c | 9 +++-- > fs/iomap/buffered-io.c | 14 ++++--- > fs/verity/verify.c | 9 +++-- > include/linux/bio.h | 91 +++++++++++++++++++++--------------------- > include/linux/bvec.h | 15 +++++-- > 5 files changed, 75 insertions(+), 63 deletions(-) .... > diff --git a/include/linux/bio.h b/include/linux/bio.h > index f86c7190c3..7ced281734 100644 > --- a/include/linux/bio.h > +++ b/include/linux/bio.h > @@ -169,6 +169,42 @@ static inline void bio_advance(struct bio *bio, unsigned int nbytes) > #define bio_for_each_segment(bvl, bio, iter) \ > __bio_for_each_segment(bvl, bio, iter, (bio)->bi_iter) > > +struct folio_vec { > + struct folio *fv_folio; > + size_t fv_offset; > + size_t fv_len; > +}; Can we drop the "fv_" variable prefix here? It's just unnecessary verbosity when we know we have a folio_vec structure. i.e fv->folio is easier to read and type than fv->fv_folio... Hmmm, this is probably not a good name considering "struct pagevec" is something completely different - the equivalent is "struct folio_batch" but I can see this being confusing for people who largely expect some symmetry between page<->folio naming conventions... Also, why is this in bio.h and not in a mm/folio related header file? Cheers, Dave. -- Dave Chinner david@xxxxxxxxxxxxx